• Nie Znaleziono Wyników

Temat: Funkcja logiczna Jeżeli Funkcja JEŻELI

N/A
N/A
Protected

Academic year: 2021

Share "Temat: Funkcja logiczna Jeżeli Funkcja JEŻELI"

Copied!
2
0
0

Pełen tekst

(1)

Temat: Funkcja logiczna Jeżeli

Funkcja JEŻELI składa się z następujących elementów:

=JEŻELI(test_logiczny; wartość_jeżeli_prawda; wartość_jeżeli_fałsz) 1. test logiczny: ta część funkcji sprawdza czy spełniony jest założony warunek

a) np. czy w komórce A1 jest wartość większa niż 0.

W zapisie funkcji warunek ten będzie wyglądał następująco: A1>0.

b) W przypadku testu logicznego można się posługiwać takimi operatorami jak: =, >, <, >=, <= . c) Jeżeli warunek ma się odnosić do wartości tekstowej wartość tę należy ująć w cudzysłów, np. zapis

sprawdzający czy w komórce A1 jest wyrażenie "bdb" będzie następujący: A1="bdb"

2. wartość_jeżeli_prawda: ta część funkcji jest wykonywana jeżeli spełniony jest założony warunek testu logicznego.

3. wartość_jeżeli_fałsz: ta część funkcji jest wykonywana jeżeli nie jest spełniony założony warunek testu logicznego.

Przykład:

=JEŻELI(A2=”Warszawa”; „stolica”; „inne”)

Jeżeli wartość w komórce A2 będzie słowem Warszawa, to w komórce, w której ma być wprowadzona funkcja JEŻELI pojawi się słowo stolica, jeśli będzie to inne miasto, wówczas pojawi się słowo inne.

=JEŻELI(A2=5; „bdb”; „inna”)

Jeżeli wartość komórki A2 równa się 5, to w komórce, w której wprowadzona jest funkcja JEŻELI pojawi się wartość słowna „bdb”. W innym wypadku pojawi się wartość słowna „inna”.

Ustalając test logiczny lub wartość dla prawdy i fałszu musimy pamiętać o zasadzie:

Gdy używamy słów, piszemy je w cudzysłowach, np.: A2=”stolica”

Gdy zaś piszemy wartości liczbowe cudzysłowów nie używamy, np.: A2>=5

Temat: Zagnieżdżona funkcja JEŻELI

Gdy mamy do wyboru dwie wartości, to wybór jest prosty – jedna z nich jest prawdziwa a druga fałszywa. Ale wyborów może być więcej:

Przykład:

W kolumnie C z oceną pogody przyjmujemy założenie:

Jeżeli jest słonecznie – pogodę oceniamy jako ładną

Jeżeli jest pochmurno – jako znośną Jeżeli jest deszczowo – jako brzydką

(2)

Składnia zagnieżdżonej funkcji Jeżeli:

=Jeżeli(B2=test logiczny1; wartość dla prawdy; Jeżeli(B2= test logiczny2; wartość dla prawdy; Jeżeli(test logiczny3;

wartość dla prawdy)))

Składnia zagnieżdżonej funkcji Jeżeli dla podanego przykładu:

=JEŻELI(B2="słonecznie"; "ładna"; JEŻELI(B2="pochmurno"; "znośna"; JEŻELI(B2="deszczowo"; "brzydka"))) Wynika z tego, że po podaniu testu logicznego piszemy wartość dla prawdy, a zamiast nieprawdy stawiamy kolejny warunek JEŻELI.

Temat: Zagnieżdżona funkcja JEŻELI z zakresem liczb

Przykład:

Weźmy sytuację, że musimy określić czy ktoś jest geniuszem, przeciętnym, czy poniżej przeciętnej w teście psychologicznym:

Jeśli ktoś uzyskał w teście co najmniej 150 punktów – jest geniuszem Jeśli mniej niż 150 punktów, ale nie mniej niż 100 punktów – jest przeciętny Jeśli zaś 100 punktów lub mniej – jest poniżej przeciętnej

= JEŻELI (A2>=150; „geniusz”; JEŻELI (ORAZ (A2<150; A2>100); „przeciętny”; JEŻELI (A2<=100; „poniżej przeciętnej”)))

Jeżeli mamy do czynienia z zakresem liczb, w podanym przykładzie jest to 149-99 punktów, stosujemy składnię z funkcją pomocniczą ORAZ:

JEŻELI (ORAZ (A2<150; A2>100); „przeciętny”;

POWODZENIA

Cytaty

Powiązane dokumenty

Wykonawca,który polega na zdolnościach lub sytuacji innych podmiotów musi udowodnić zamawiającemu, że realizując zamówienie, będzie dysponował niezbędnymi zasobami tych

kreatywności – myślenie matematyczne; Program szkolenia (150h) dla drugiej grupy powinien uwzględniać poniższe zagadnienia: II. nauka wybranych języków programowania. W

Wykonawcę oświadczenia o spełnianiu warunków udziału w postępowaniu zgodnie z załącznikiem nr 3 do SIWZ (W przypadku Wykonawców składających wspólną ofertę, Oświadczenie

ogólnodostępnych i bezpłatnych baz danych, Zamawiający pobierze samodzielnie z tych baz danych wskazane

długości, co najmniej 2,0 km i udokumentuje, że usługa ta została wykonana należycie. Ocenę spełniania warunku udziału w postępowaniu Zamawiający przeprowadzi na podstawie

IV.6.4) Przewiduje się unieważnienie postępowania o udzielenie zamówienia, w przypadku nieprzyznania środków pochodzących z budżetu Unii Europejskiej oraz niepodlegających

o powierzchni co najmniej 1.500 m2 każde. Ocena warunku według: - oświadczenia Wykonawcy – wg załącznika nr 1 do Instrukcji dla Wykonawców Rozdział II siwz oraz - załącznika nr

8 do SIWZ wykazu dostaw wykonanych, a w przypadku świadczeń okresowych lub ciągłych również wykonywanych, w okresie ostatnich 3 lat przed upływem terminu składania ofert, a